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4 FRC SOFTWARE INSTALLATION  

 

4.1 SOFTWARE INSTALLATION INTRODUCTION 
This section of the control system manual provides detailed steps for the installation and 
configuration of the programming environments for the 2009 FRC Control System. 

 

Two programming environments are available for use by teams:  National Instruments LabVIEW, 
which supports a graphical programming language, and Wind River Workbench, which supports C 
and C++ languages.  After compiling, executables are transferred to the cRIO, which runs the Wind 
River VxWorks 6.3 operating system. 

 

4.1.1 Special Note for Teams Receiving the “Early Control System Shipment” 
Teams receiving an “early control system shipment” are requested to carefully follow the steps 
below, recording any deficiencies, confusing points, errors, and/or possible improvements to the 
installation procedures so that this document can be improved for the use by all teams.  Please post 
your detailed suggestions in the appropriate discussion on the FIRST Control System Support Site. 

 

4.2 INSTALLING THE FRC PROVIDED SOFTWARE 
The Install DVDs in the new control system kit contain the FRC versions of the following tools: 

DVD 1: National Instruments (NI) LabVIEW 8.5.1 and other NI tools, including NI Measurement and 
Automation Explorer, NI Vision Assistant, NI-RIO, and NI cRIO Imaging. 

DVD 2: Wind River Workbench for C/C++ programming, FRC specific version. 

 

4.2.1 Licensing 
The National Instruments LabVIEW license is active until January 15, 2010.  The Wind River 
Workbench license is active until January 5, 2010. 

Teams are permitted to install the software on as many team computers as needed, subject to the 
restrictions and license terms that accompany the applicable software, and provided that only team 
members or mentors use the software, and solely for the FRC.  Rights to use LabVIEW and 
Workbench are governed solely by the terms of the license agreements that are shown during the 
installation of the applicable software. 

 

4.2.2 Installation Requirements 
The installation has been tested on the following operating systems: Windows XP, Vista. 

To install, you must be logged on as an administrator or as a user with administrator privileges. You 
will need Internet access to activate the Wind River and NI Licenses. 

 

4.2.2.1 Requirements for the LabVIEW Programming Environment 
Installation of the “LabVIEW Package” from the FRC DVD requires 3.6 GB total disk space.  On a 
Windows XP platform, this package takes an average of 1.5 hours to install.  Installation on a Vista 
operating system sometimes takes longer. If you currently have National Instruments software on 
your PC, it will not interfere with that installation. 

 

4.2.2.2 Requirements for the C/C++ Programming Environment 
Installation of the “Wind River Package” from the FRC DVD requires 2.4 GB total disk space.  Note 
that even the C/C++ programming environment will require installation of many portions of the NI 
software to support the cRIO.   On a Windows XP platform the Wind River software takes an 
average of ½ hour to install. The FRC installation must be installed in the directory ”c:\WindRiver”.  
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A different version of Workbench on your PC can remain installed, but it must be in a different 
directory. 

Users of the software must read the license agreements that are shown during installation of the 
software carefully and completely. 

 

4.2.2.3 Requirements for Both Programming Environments 
Both programming environments (the “LabVIEW Package” and the “Wind River Package”) installed 
together require 4.6 GB total disk space, taking an average of 2 hours to install. 

 

4.2.3 Before Installing 
 

4.2.3.1 Deactivate / Uninstall software 
 

1. Disable any automatic virus detection programs before you install. Some virus detection 
programs interfere with installation.  (NOTE:  Some of the beta test teams that did not 
disable virus detection before installation needed to re-install their programming 
environments again to remedy problems encountered in installation.)  

2. If you have the FIRST Tech Challenge software installed, use the Switch Palette Set dialog 
box, accessible by selecting Tools»Switch Palette Set in LabVIEW, to switch to the 
Complete LabVIEW palette set before installing the FRC software. 

3. If you have another version of the Wind River Workbench installed, make sure it is not in the 
C:\WindRiver directory because that is the preferred location for the FRC installation (some 
of the tools expect that location). 

 

4.2.3.2 Obtain licenses 
The install DVD jacket has the serial number to use for LabVIEW activation. If this is not available, 
LabVIEW may be activated temporarily for 30 days without a license.   

The Wind River Workbench License Authorization Code (LAC) is pre-populated in the installer. 

 

4.2.4 Install LabVIEW 8.5.1 and Associated Components 
 

4.2.4.1 Installation Procedure 
Insert the FIRST Robotics Competition Software installation DVD 1 and follow the instructions that 
appear on the screen. 

 

4.2.4.2 Activation Procedure 
After the NI software is installed, an NI Activation Wizard starts. (This may happen while the second 
installation disk is working). Activate the product using the serial number obtained from NI. If no 
serial number is available, use the 30-day temporary activation option. 

 

If you obtain a license later, follow this procedure to activate LabVIEW permanently:  

1. From the Start Menu, select:  Programs >> National Instruments >> NI License Manager 

2. The License Manager dialog asks you what you would like to activate.   

Choose "Automatically activate thru a secure internet connection.” 

You only need to enter in the number for LabVIEW 8.5.1 Development System.   

This will activate all the National Instruments programs that you need for FRC. 

3.  Press the Activate Button. 
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4.2.5 Install Wind River Workbench 3.0 and Workbench Update for FRC 
 

4.2.5.1 Installation Procedure 
Note: If you have just installed the previous DVD, the National Instruments Activation Wizard may 
start while Workbench is being installed. Internet access is needed to complete the install for 
Workbench. 

 

Insert the FIRST Robotics Competition Software installation DVD 2 and follow the instructions that 
appear on the screen.  The installer should launch automatically, as shown: 

 

 

 

• The “Installer-Welcome” dialog window should appear (as shown above), indicating that the 
Wind River General Purpose Platform VxWorks Edition 3.3 including VxWorks 6.3, 
Workbench 3.0.1, GNU Compiler 3.4.4, and Wind River Compiler 5.4.0 will be installed.  
Select “Next” to continue. 
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• The “Installer-License Agreement” dialog window should appear, as shown above.  Review 
the license agreement, select “I ACCEPT the terms of this license agreement.” And select 
“Next” to continue. 

•  

 

• The “Installer-Installation Directory” dialog window should appear.  Accept the default 
installation directory of “C:\WindRiver” and select “Next” to continue.  (If the directory does 
not yet exist, a new dialog will appear asking if you want to create it.  Select “Yes” to create 
the directory.) 
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• The “Installer-Choose Activation Type” dialog window should appear.  Select “Temporary  
activation.”   Select “Next” to continue.   

 

• At this point a “Host Information” dialog window may appear. If so, select the Disk Serial 
Number as the host ID to identify the computer. 

• Select “Next” to continue. 
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• The “User Information” dialog window should appear, with a pre-populated License 
Activation Code (LAC).   

• Enter your user information as requested. 

 

• At the Installer - User Information window, all participants and mentors must provide 
their information for product registration.  Wind River maintains this information as 
confidential.  Product registration is a necessary step of the installation process, without 
which installation is not completed.  

FIRST mentors and participants should provide their FIRST specific information to these fields: 

1 Under User Name, please add identification as a "Mentor" or "Competitor". 

2 For Company, please list your School name and FRC Team number. 

3 For Phone, provide the School phone number or your mentor's contact number. 

Please note that fields marked with a red asterisk cannot be left blank in order to proceed. 

  

The registration process connects to a Wind River server, which requires users to have an Internet 
connection active when installing.  User information is confirmed and the installation keys are 
supplied in return.  

Important Note: Once, the install is underway and progress bars have appeared on the Installer- 

Standard Installation window, connectivity to the Internet is no longer needed to install and run 
Wind River software. 
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• Select “Next” to continue. (Licensing will be automatically installed on your Windows host). 

 

 

 

 

• The “Installer-Choose Installation Filters” dialog window should appear.  Ensure that the 
target architecture selected is “PowerPC.”  Select “Standard Installation” and then select 
“Next” to continue. 
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• The “Installer-Standard Installation” dialog window should appear.  Note that each of the 
following tools should be listed: 

o Wind River Workbench 3.0 

o Wind River Compiler 5.4.0 

o Wind River GNU Compiler 3.4.4 for VxWorks 6.3 

o VxWorks 6.3 and General Purpose Technologies 

o VxWorks 6.3 BSPs for PowerPC 

o VxWorks 6.3 Vista Point Patch 

o WPI  and NI Patch for Workbench 3.0 and VxWorks 6.3 

o License Patch for Workbench 3.0 and VxWorks 6.3 

Select “Install” to proceed with the installation.  (The installation will take about 30 minutes 
on XP and possibly more than one hour on Vista PCs.) The licensing will be automatically 
installed on the PC. 

 

 

 

• After the “Overall Installation Progress” meter shows that installation has completed, select 
“Next” to continue. 
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• The “Installer-readme.txt” dialog will be shown.  Review the “readme” information and select 
“Next” to continue. 

• The “Installer-Finish” dialog will be shown.  Please deselect the “Launch Wind River 
Workbench 3.0” checkbox so that you can upgrade the Workbench Installation with the 
latest FIRST software (see the next section) before running Workbench.  According to your 
preference either deselect or select the “Create a desktop icon for Workbench 3.0” 
checkbox.  Select “Finish” to complete the installation of Workbench 3.0. 

 

4.2.5.2 Upgrading the Workbench Installation with latest FIRST software 
After installing the Workbench software from the DVD, it is necessary to apply a patch to upgrade 
the installed software to the latest version in order for the C/C++ software to be compatible with that 
in the latest cRIO image.  Please follow the steps below in order to upgrade your Workbench 
software: 

• Go to http://www.usfirst.org/frccontrolsystem and follow the link for “C/C++ updates for 
WPILib software update” and download the latest update. 

• Run the executable that you saved on 
your computer.  You will see the 
“WinRAR self-extracting archive” 
welcome screen.  (Shown at right.) 

• The archive utility will extract itself to 
C:\Temp and then install the appropriate 
files your WindRiver installation in 
C:\WindRiver.  Click “Install” to continue. 

• A command window will be shown briefly 
during installation.  When the WinRAR 
window and command window both 
close, the installation of the Workbench 
patch for the latest FIRST code is 
complete.  
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4.2.5.3 Starting Wind River Workbench 3.0.1 for the First Time 
Start the Wind River Workbench up via “Start -> All Programs -> Wind River -> Workbench 3.0 -> 
Workbench 3.0”. 

 

 

• The Wind River Workbench 3.0 “splash screen” should appear, shortly followed by the 
“Workspace Launcher” dialog window.  Accept the workspace location of 
c:\WindRiver\workspace and select “OK” to continue. It is highly recommended that you use 
this default workspace so that the default code library mappings will work. 

 

• NOTE:   If you are running a Windows Firewall, you may observe dialog windows requiring 
you to allow various features with the publisher of Wind River Systems. 

 

The Wind River Workbench will appear with a single large “Welcome” pane.  You can make use 
of the welcome pane features (Overview, etc.) or close the “Welcome” pane by clicking on 
the “x” next to the “Welcome” tab. 

 

4.3 INSTALLING ESSENTIAL UPDATES 
The software provided on the DVD is no longer the most recent software versions available to 
teams.  There are additional software updates that must be installed. 

 

4.3.1 Installing NI Updates 
Visit http://joule.ni.com/nidu/cds/view/p/lang/en/id/1180 to download the most recent NI Update and 
install it as described on that web page. 

 

4.4 INSTALLING ADDITIONAL SOFTWARE FOR THE C/C++ PROGRAMMING 
ENVIRONMENT 

 

4.4.1 Subversion 
Source code is controlled on the WPI site in a Subversion (SVN) repository. There are many 
subversion clients, but some that are useful are the SVN plugin for Eclipse (Subclipse), Tortoise 
SVN, which integrates nicely with the Windows explorer, and SlikSVN, a standalone command line 
Subversion client.  
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Caution:  The C/C++ version of WPILib uses an option in SlikSVN to display version numbers.  If 
you compile WPILib from source code and do not have SlikSVN installed, you will see an error 
when compiling WPILib from source, but the code will compile and run without it. 

 

4.4.1.1 Install the SVN plugin for Eclipse / Wind River Workbench 
After clicking on the “x” next to the Welcome tab, the standard “Application Development – Wind 
River Workbench” window will be shown.   To acquire the latest WPILib software for the FRC 2009 
Controller, first install the Subversion plug-in for Workbench, as follows: 

• Begin the installation from the Workbench (Eclipse) Help menu item:  “Help -> Software 
Updates -> Find and Install…” 

• The “Install/Update” dialog will appear; select “Search for new features to install” and select 
“Next” to continue. 

• The “Install” dialog will appear.  Click the “New Remote Site”…  button. 

• A “New Update Site” window will appear.  In the “Name” field, enter “Subclipse” and in the 
“URL” field, enter http://subclipse.tigris.org/update_1.4.x  Click “OK” to add this site to the list 
and dismiss the “New Update Site” dialog window. 

• Back in the “Install” dialog, observe that the “Subclipse” update site is now included in the 
list and checked.  Click on the “Subclipse” line in the list to ensure that it is selected, and 
then click on “Finish” to proceed with the installation of the update. 

• After checking the website, the “Updates” dialog should appear.  Expand the “Subclipse” 
item in the list to show the subcomponents.  Select the “JavaHL Adapter (recommended)” 
line and the “Subclipse (required)” line so that both of these items are checked.  Then select 
“Next” to continue. (DO NOT check the “Integrations” or “SVNKit Adapter BETA” boxes.) 

• The “Feature License” dialog should appear.  Review the license agreement, select “I 
accept the terms in the license agreement” and then select “Next” to continue. 

• The “Installation” dialog will show the features to be installed (Subclipse, Subversion Client 
Adapter and Subversion Native Library Adapter (JavaHL)).  Select “Finish” to perform the 
installation. 

• The “Verification” dialog will likely appear, warning that the feature to be installed has not 
been digitally signed.  Select “Install All” if you approve the installation of an unsigned 
feature. 

• The “Install/Update” dialog will appear, indicating that Workbench needs to be restarted for 
the changes to take effect.  Select “Yes” to restart Workbench. 

 

4.4.1.2 Install Tortoise SVN Subversion Client 
TortoiseSVN is not required for use of the WPI subversion server, but is a very helpful utility for 
Windows.  It provides an alternative SVN interface using the Windows Explorer, without requiring 
Wind River Workbench to be running. If you plan to use Subversion for source control TortoiseSVN 
will enable you to access files directly from the Windows Explorer. When TortoiseSVN is installed, 
right clicking on a file in the Explorer displays the SVN options available. To download and for more 
information, see http://tortoisesvn.net/downloads 

 

4.4.1.3 Install SlikSVN Command Line Subversion Client 

SlikSVN is not required for use of the WPI subversion server, but it is used in the compilation of 
WPILib in order to embed version information in the built executable.  If you intend to build WPILib 
from source code, we highly recommend installing SlikSVN to avoid spurious error messages when 
compiling WPILib.  See http://www.sliksvn.com/en/download  
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4.4.2 Using Wind River Workbench to Create Projects and Build Robot Code 

For detailed information on the WPI Robotics Library and how to use Workbench to build robot 
code, please see the C/C++ Programming Guide for FRC. This document is included in the 
installation in the WindRiver/docs/extensions/FRC directory. Updated versions will be posted on the 
FIRST Web Site at http://www.usfirst.org/community/frc/content.aspx?id=10934 with the 2009 FRC 
Control System Manual. 
 

4.4.3 Installing the FRC 2009 WPILib Source Code 

4.4.3.1 Install from the WPI SVN Repository 
If you do not wish to compile WPILib from source code, please skip this section. 

• After having installed the Subclipse plugin, to acquire the software for the FRC 2009 
Controller, select “File->New->Project…” 

• The “New Project” dialog will appear.  Select “SVN->Checkout Projects from SVN” and then 
select “Next” to continue. 

• The “Checkout from SVN” dialog will appear.  Select “Create a new repository location” and 
“Next”.  Enter the URL of ***coming soon*** and select “Next”. 

• In the “Select Folder” dialog, expand the “CProgramming” folder, then the “trunk’ folder, and 
then select the “WPILib” folder.  After selecting the “WPILib” folder, select “Next”. 

• The “Check Out As” dialog will appear; select “Check out as a project in the workspace” 
(accepting the default name of WPILib) and select “Next”.  Accept the default workspace 
location and select “Finish”.  WPILib will be checked out into your workspace. 

• NOTE:  Sometimes when checking out a project from SVN, the project type is indicated as a 
"Native Application (Host OS) Project" rather than as a "Wind River VxWorks 6.3 
Downloadable Kernel Module Project" as defined in the SVN repository.  A workaround for 
this problem can be performed as follows: 

o Exit Workbench and then restart Workbench immediately after checking out the 
project from SVN.  (Before attempting to build the just-checked-out project.) 

o When Workbench restarts, an "Intializing Workspace" dialog appears and changes 
the project type to the correct type! 

 

4.5 CHANGING BETWEEN WIND RIVER AND LABVIEW PROGRAMMING 
ENVIRONMENTS ON THE CRIO  

The Imaging tool documented in Section 5 is used to switch environments without requiring re-
imaging of the cRIO. The “ni-rt.ini” file on the cRIO requires different settings for the two 
environments. The Imaging tool updates this file based on the environment specified. For detailed 
instructions see the section titled “Update Firmware on cRIO”. 

 

4.6 USING WIND RIVER WORKBENCH  
 

The C/C++ Programming Guide for FRC (see reference section) contains instructions for 
configuring Workbench, creating, running and debugging programs in the Workbench environment. 

Workbench also has extensive help documents. New users are encouraged to do the “Getting 
Started” Tutorial under Wind River Documentation. For the FRC installation, some features of 
Workbench are disabled, and others are not used in the FRC environment using the cRIO target. 
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4.7 TROUBLESHOOTING 
 

4.7.1 Wind River Workbench 

4.7.1.1 Slow Startup  
The first time the workbench starts; it takes longer because it is initializing the workspace. After that 
it scans the workspace every time it starts. If your workspace is set to the C: drive instead of 
C:/WindRiver/workspace, this scan can take a long time. We have also encountered an issue with 
the antivirus Sophos that slowed the startup significantly.  

 

4.7.1.2 License Issues 
“System Time has changed” – On startup, WindRiver checks every file on the filesystem to see if 
the creation or last modified date of each file and folder is later than the current date. 
        To fix this error, you can delete all files and folders with a creation date later than the current 
date or get a program that can modify the creation date. 
        For files with a last modified date later than the current date, you can open the file then save it. 
For folders with a last modified date later than the current date, you can create a folder inside the 
offending folder then delete it. 
        Another possible solution is to run Workbench in a virtual machine. This should also increase 
the startup time of Workbench, as it would only check the files in the virtual machine. (We didn’t try 
this). 

 

4.7.1.3 Other Issues 

See the C/C++ Programming Manual for Troubleshooting tips for Workbench Usage. 

 

4.8 FOR MORE INFORMATION 
 

4.8.1 FIRST  
For programming support, forums and links, see: www.usfirst.org/frccontrolsystem  

 

4.8.2 LabVIEW 
Getting Started with LabVIEW for the FIRST Robotics Competition 

This manual covers the LabVIEW graphical programming environment and the basic LabVIEW 
features you can use to build FRC applications. 

To access this file, go to: http://decibel.ni.com/content/docs/DOC-2451 

 

Robotics Programming Guide for the FIRST Robotics Competition 

This manual provides information about robotics programming concepts, reference information 
about the FIRST Robotics Competition VIs, and guidelines for troubleshooting in LabVIEW. Access 
To access this file, go to: http://decibel.ni.com/content/docs/DOC-2631 

 

 

4.8.3 Wind River Workbench 
Wind River Workbench User's Guide 

Use the Wind River Workbench User's Guide to access information about building and debugging 
an application in the Wind River programming environment.  

To access this file, in the Workbench, select Help»Help Contents. Then on the Contents tab of the 
Help – Wind River Workbench help window, navigate to the Wind River 
Documentation»Guides»Host Tools»Wind River Workbench User's Guide 3.0, VxWorks Version 
book 
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4.8.4 FRC/WPI Robotics Library 
C/C++ Programming Guide for FRC  

This is the definitive source of information about WPILib, and includes FRC-specific usage 
information for Workbench. This guide describes using the WPILib C++ library and how to create 
projects with WindRiver Workbench. 

This document is provided with the Workbench install under WindRiver>Docs>Extensions>FRC 

Updates can be obtained from  www.usfirst.org/frccontrolsystem 

 

Doxygen output for WPILib C Library 

This is the definitive source of information about WPILib. It is derived from comments extracted 
from the source code. You should unzip it into a directory, then open index.html with a browser. To 
access go to: http://users.wpi.edu/~bamiller/WPIRoboticsLibrary/ 

 

4.8.5 FRC Vision Specification (C/LabVIEW) 
Includes both the LabVIEW and C Programming interfaces to the vision libraries for image 
processing. 

This document is provided with the Workbench install under WindRiver>Docs>Extensions>FRC 

Updates can be obtained from www.usfirst.org/frccontrolsystem 

 

 

 


