FRC LabVIEW Sub-vi Example

Realizing you have a clever piece of code that would be useful in lots of places, or wanting to un-clutter your program to make it more

understandable, you decide to put some of it into a sub-vi...

Example A — The easiest way to create a sub-vi is from existing code

What makes this approach especially easy is that the vi inputs/outputs will automatically be setup for you without requiring you to create each one manually.

Step 1:

Highlight the code to become the new vi, making sure the

inputs and outputs you’ll want remain outside the
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Step 2:
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Example B — A similar example that goes into some common extras

e Create subvi

e Saveit

e Change theicon

e Add a new additional input
e Make reentrant

Create a subvi
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Create a new vi from scratch, using Edit -> New VI, in a new blank window or
create one from highlighted existing code.

In existing code isolate the segment you’ll make into a new vi.
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Highlight the new vi code




I Select File -> Create SubVi
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Your new vi appears in place of the code you highlighted.
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It's given a default generic numbered icon.

It is ready to go, and will do the same job as the original code did, but does
need to be saved before you can run it.
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If you forget to save LabVIEW will remind you when you build, deploy, or close
the project.
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Saving the new subvi:

" project Explores - Examplesivp - (o] x| P project Explores - Examples.vp —Iox| | The new vi must be given a name and saved as part of your
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Change the Icon:
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VI Properties

Show Connector

Add Terminal
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1. Open the new vi by double-clicking in the default icon it was given,
or by double-clicking on the filename in Project Explorer.

2. Right-click on the picture of the icon in the upper right of the front
panel window.

Remoye Terminal
Patterns: 2
Rotate 90 Degress . .
ke || ip oo 3. Choose Edit Icon... to begin
@ Flip Yertical
DL | Disconnect All Terminals
[Examples. lvpra Lisconnect This Termins| ’4'
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You’ll get a popup editing window with the icon
o A paint-style tools menu on the left gives you some basic drawing
X .
Fie Edt Hep capabilities.
B & Copy from:
= %‘ You can also copy and paste artwork from other places to add to your icon.
16 asecoos | e There’s a link to an NI webpage of some common artwork you can
[~ show Terminals
use.
256 Colors . 3 )
o | e Or use Edit->Import Picture to Clipboard... & paste
Cancel ° . . .
| —IHEID Or drag & drop any graphic/photo file to the upper right corner of

the front panel or block diagram and it will be converted to a 32 x 32
pixel icon. Make sure the graphic is square, otherwise it’ll end up
squeezed or stretched looking.

Icons are 32x32 pixels

Pencil—Draws and erases pixel by pixel. To draw horizontal or vertical
lines, press the <Shift> key while you use this tool to drag the cursor.

Line—Draws straight lines. To draw horizontal, vertical, and diagonal lines,
press the <Shift> key while you use this tool to drag the cursor.

Color Copy—Copies the foreground color from an element in the icon.
Fill—Fills an outlined area with the foreground color.

Rectangle—Draws a rectangular border in the foreground color. Double-
click this tool to frame the icon in the foreground color.

Filled Rectangle—Draws a rectangle with a foreground color frame and
filled with the background color. Double-click this tool to frame the icon in
the foreground color and fill it with the background color.




Select—Selects an area of the icon to cut, copy, move, or make other
changes. Double-click this tool and press the <Delete> key to delete the
entire icon.

Text—Enters text into the icon. Double-click this tool to select a different
font. While text is active, you can move the text by pressing the arrow
keys.

Foreground/Background—Displays the current foreground and
background colors. Click each rectangle to access a color picker.

Here’s a freehand example...
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Click OK and you’ll see your new icon applied immediately in all your vi's.

Here's a quick run through that adds pre-made artwork (limited to 32x32
pixels). These can be produced in any graphic editing utility, or found on the
web.

Edit -> Import Picture to Clipboard...

and browse to a picture or graphic file of some sort . This just puts the
picture in the clipboard. It won’t appear anywhere yet.
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Use Edit -> Paste to add your clipboard picture to the icon
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Use the arrow keys to reposition the new addition on the icon
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This is what it looks like after you click OK
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Add an Input:

This same instruction holds for creating new outputs as well.
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Start by opening the front panel of your vi.
<- This is the example we'll use

The subvi restricts motor movement in one direction based on a limit switch
input.

Inputs are:

e Joystick axis to drive a motor

e Limit switch to stop the motor if it goes too far in just one direction
Outputs are:

e The motor speed

B! ntitied 2 (Sub¥1) Front Panssj [m] |F3

File Edt View Project Cperste Tools
WI Properties
Edit Icon...

Find &ll Instances

Add Terminal

Remave Terminal
Patterns
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1. First we need to add a place to connect the new input.

Right-click on the icon in the upper right of the front panel and choose
Show Connector
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The icon will change to a sub-divided box with smaller colored boxes for any

pre-existing inputs and outputs.

In this case there are two input boxes on the left colored orange (the joystick
axis is a floating point number) and green (the digital input is a Boolean), and
one larger orange box (motor speed is a floating point number) for our single

output on the right.

We'll need to add a new place to connect our new input.
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2. Add the new input you want.

Here we’re going to add a new Boolean that can be used to override
the limit this subvi is enforcing.

e Right-click on the front panel to get the controls palette, go to Boolean
controls and choose one style.

e Place the new control on the front panel
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This is what it now looks like with the new input control called “Override”




B Untitled 2 (SubvI) Frant PoRRRP =1 1| 3. Change the connector pattern to make room for the new input.
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e Right-click on the connector in the upper right of the front panel

Find &ll Instances

e Choose Patterns to see lots of variations for how 1/O can connect to
your subvi.

Add Terminal
Remove Terminal
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90 Degrees

Flip Horizontal

Flip Yertical
Disconnect All Terminals |

e Choose any one of the patterns that appeal to you. You just need to
choose one that has as many or more open boxes than you have inputs
and outputs.

Disconnect This Terminal
This Connection Is
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P untitled 2 (sub¥i) Front Panen (=] £ We picked a pattern that had just enough open boxes. Three on the left for our
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LabVIEW will keep the I/O connectors already defined, but depending on how
BEELECL a2 radical you new pattern is, they may get put in different spots than you’d like
i them to be. You can reorder any of the existing 1/O connections just as we’ll
- show how to add your new input.
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A white box means nothing is connected there.

4. Make the connection

e Click on the white connector, then

e Click on the input that should be attached to that connector.

The white connector will take on the color of the input data type.
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Open the subvi’s block diagram and you’ll see the new input you added just

floating off by itself, not doing anything.

Overtide axis 2 (y) B You need to wire that into place.
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LAt For this example this new override input will control a case statement that
e applies the limit switch or overrides it altogether.
=
e Add a case around the code
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e Right-click on the edge of the case structure and choose Make This
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Remove Case Structure

Add Case After
Add Case Before
Duplicate Case
Delete This Case

Show Case False

Properties

Case False to switch the True/False cases so that the code is applied in
the False case and bypassed in the True case.
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This is what it should look like now.
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In this example we’ll add a joystick button to control our new override
input.

e Copy the axis unbundle by name

e Wire the new unbundle to the Joystick Get button output
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6. Relink the subvi wherever it’s used.

e Whenever you change the input/output connector LabVIEW wants you
to inspect each use of the subvi to be sure inputs/outputs are still
wired correctly. So a vi with a changed connector pattern will be
grayed out wherever it’s used in a block diagram.

e Right-click on the grayed out icon and choose Relink To SubVI

The subvi icon will no longer be grayed out.
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7. Attach the new override button to the new subvi input.
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All done

Remember to Document it

Contert Help ﬂ

subviDelayedEvent.vi

Trigger -
Delay in miliseconds

The trigger causes a delaved event that can be

used to perform another event sometime later.
The delay timer is restarted each time the trigger is
true.

An additional check can be added to prevent
restarting if desired.

Category I Diocurnentakion LI

%1 description

The trigger causes a delawed event that can be used to perfarm another event sometime later, o
The delay timer is restarted each time the trigger is true.
An additional check can be added ko prevent restarting if desired.

Help kag Help path

Browse..,

ok | Cancel | Help |

Edit -> VI Properties

Go to Documentation on the Category pull-down and enter description and
useful information.

The inputs, outputs and icon will automatically be added at the top of the
Context Help for your new vi with your descriptive text underneath.




Make reentrant for multiple uses:

This is only necessary if the subvi is preserving specific data about a particular call, such as a start or end time via feedback nodes AND you want to use it in more
than one place. Normally a new subvi is not reentrant and this means if it’s called from multiple places they all have to line up and wait their turn to use the
subvi, and you should not try expect data to be untouched from call-to-call.

By default there is just one copy of a new subvi running in your program. This is normally how you want to run as long as the subvi is doing something straight
forward like doing a calculation or measurement and doesn’t have to remember or distinguish between calls. Making a subvi reentrant causes each call in your
code to be it's own unique copy, so that it will preserve data that has to be remembered from call to call and not get mixed up with when it’s called in other
places which also have to remember states, time, counts, or whether buttons have already been pushed.
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B} v1 Properties x| In the pop-up properties window use the pull-down to go
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 General
Mermory Usage
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Revision History
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Current revision Location Protection
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P ¥I Properties

Category I Execution

=

Priority
I niormal priarity _vI

etween instances
({reduces memary usage)

¢& Preallocate done For each instance
{maintains state for each instance)

Preferred Execution System
| same as caller - |

[V Enable automatic error handing

[~ Run when opened
[~ Suspend when called
[” Clear indicators when calld

[V Aute handle menus at launch

oK I Cancel Help

Click Reentrant execution
Choose Preallocate clone for each instance

This gives each instance it's own memory to preserve each
unique state.




